Servers don't reliably update with script anymore

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Servers don't reliably update with script anymore

Absurd Minds
I don't know what the problem is, but all of my servers have a nearly identical startup script which includes -autoupdate -steam_dir /home/servers/go/steamcmd -steamcmd_script server1.txt

The script for each of these servers looks something like this:


login username password
force_install_dir /home/servers/go/server1/
app_update 740
exit


For some reason, for each of the most recent updates, about half the servers haven't updated, even though the servers restart nightly. I found one server that was still running version 1.35.7.9. I'm just lucky that nobody ever plays in my servers. Haha. Ha.

Any ideas what could be causing the issue?

(i'm running ubuntu)

_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Servers don't reliably update with script anymore

Sven 'Chaos' Pachnit
I just have 4 servers running and I semi-autoupdate them in that I manually have to start the otherwise automatic process.
Therefore I’m always a few hours late in case this should affect update availability but I had no problems with this update (but I also monitor my server versions so I would immediately see if a server hadn’t updated).

The only thing I do differently is that I update my servers like so (#{p} is the server’s install path, I’m using a ruby script to update my servers):

cd #{p} && ../steamcmd/steamcmd.sh +login anonymous +force_install_dir #{p}/ +app_update 740 validate +quit

That has always worked for me so far, never had a server not updating or something.

Maybe that helps :)


Am 24.05.2017 um 20:26 schrieb Absurd Minds <[hidden email]>:

> I don't know what the problem is, but all of my servers have a nearly identical startup script which includes -autoupdate -steam_dir /home/servers/go/steamcmd -steamcmd_script server1.txt
>
> The script for each of these servers looks something like this:
>
>
> login username password
> force_install_dir /home/servers/go/server1/
> app_update 740
> exit
>
>
> For some reason, for each of the most recent updates, about half the servers haven't updated, even though the servers restart nightly. I found one server that was still running version 1.35.7.9. I'm just lucky that nobody ever plays in my servers. Haha. Ha.
>
> Any ideas what could be causing the issue?
>
> (i'm running ubuntu)
> _______________________________________________
> Csgo_servers mailing list
> [hidden email]
> https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers


_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers
Loading...