Re: Csgo_servers Digest, Vol 5, Issue 208

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: Csgo_servers Digest, Vol 5, Issue 208

Krillins World
Once again, there isn't anything wrong with the GameModes_Server.txt file except the "traning/trainging" mode is not specified. The file modified and saved with Programmer's Note pad to ensure the files containers / syntax was correctly formed using the original gamemodes.txt as a model as you will see below.

However this may be. The problem still exists but now when a third player tried to join the game they get the "Disconnected: Failed to ping server. Please try again."

Our server launch command is:

./srcds_run -game csgo -console -usercon +net_public_adr 93.37.0.53 +hostport 27017 +game_type 0 +game_mode 1 +mapgroup mg_fullrotation +map de_dust2 +maxplayers 12 -debug

Thanks,
Doc
________________________________________________________________________________________________________________________________________
GAMEMODES_SERVER.TEXT is posted below. It has been slightly modified since posted, but none of the changes (removal of items) have made any difference with connection issues.
 


From: "[hidden email]" <[hidden email]>
To: [hidden email]
Sent: Monday, August 20, 2012 9:00 PM
Subject: Csgo_servers Digest, Vol 5, Issue 208

----- Forwarded Message -----

Send Csgo_servers mailing list submissions to
    [hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
    https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers
or, via email, send a message with subject or body 'help' to
    [hidden email]

You can reach the person managing the list at
    [hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Csgo_servers digest..."

Today's Topics:

  1. Re: Disconnected: Failed to ping server. Please try    again.
      (Flickshot Tech)
  2. pheonix the bot (Absurd Minds)
  3. Re: pheonix the bot (Gordon)
  4. steamcmd update released (Taylor Sherman)
Hey,

I had this problem a while back. Fixed by making sure the gamemodes_server file was correct.

As you can see in your Console log :

"
RememberIPAddressForLobby: lobby 186000053b7f862 from address 10.0.0.4:27017
Unknown command "joingame"
GameTypes: could not find matching game type "".
CSysSessionClient: Server ping failed

"
The problem is with your gametypes;
GameTypes: could not find matching game type "".


Here is a copy of my gamemodes_server for a classic casual server.
Then your command line your be "+mapgroup office +map cs_office"
If you were using my config that is.




// Values here override the default gamemodes.txt 

"GameModes_Server.txt"
{
"gameTypes"
{
"classic"
{
"gameModes"
{
"casual"
{
"maxplayers" "24"
"convars"
{
"sv_allow_votes" "0"
"mp_roundtime" "2"
"sv_alltalk" "0"
"sv_deadtalk" "0"
"mp_friendlyfire" "0"
}

"mapgroupsMP"
{
"office" ""
}
}
}
}
}


"mapgroups"
{
"office"
{
"name" "office"
"maps"
{
"cs_office" ""
}
}
}
}




Hope it helps,


James




On 21/08/2012, at 11:07 AM, Krillins World wrote:

Hey Folks,

     I just bought CSGO on Thursday 8/16/2012. Downloaded my client then used my account to download the CS:GO DS data for running a server on Linux (Debian 6.0 x64). After finding out how to do so and get the server up and running. Everything was going good except the GameModes_Server.txt, that was a major PIA as the .example file gave us nothing to go on at all. That in its self took hours to be sure the syntax was exact. After hours of building a GameModes_Server.txt to meet the server requirement everything was perfect except the server nagging about a "training/training" section in the FameModes_Server.txt.

     Now I go over to my client, lot onto steam, get my 'Servers' list to come up. My LAN shows the server is running, try to connect to my server and I am in my game server ready to play, which I start doing. I ask others to join me. My wife, who is on the LAN with me gets the following:

Joining Lobby... Please wait.......... and wait....... and wait....
Disconnected: Failed to ping server. Please try again.

This data is noted in the client console:
Connecting to public(10.0.0.4:27017) ...
1572.135:  Sending UDP connect to public IP 10.0.0.4:27017
Server using 'public' lobbies, requiring pw no, lobby id 186000053b7f862
RememberIPAddressForLobby: lobby 186000053b7f862 from address 10.0.0.4:27017
Unknown command "joingame"
GameTypes: could not find matching game type "".
CSysSessionClient: Server ping failed

     I was told that disabling bots fixed this issue, this was not the case at all. The problem still prevails. Today after the update I tried the same thing with same results. I open up the console to the client and type the following:

pingserver 10.0.0.4:27017 from the outside 99.37.0.53:27017

pinging 10.0.0.4:27017
Responder   : 10.0.0.4:27017
Protocol    : 17
Hostname    : K|W Simply The Best :: CS:GO ::
Map         : de_dust2
Game        : csgo
Description : Counter-Strike: Global Offensive
AppID       : 730
Players      : 1
MaxPlayers   : 10
Bots         : 0
Server Type  : dedicated
OS    Type   : Linux
Password     : no
Secure       : yes
Version      : 1.17.3.0
Game Port    : 27017
Public Tags   : l���@Krillin's World,K|W,

This is my sever launch command line:
./srcds_run -game csgo -console -usercon +ip 10.0.0.4 +hostport 27017 +game_type 0 +game_mode 1 +mapgroup mg_bomb +map de_aztec

Server as of this moment is running the stock gamemodes.txt as the custom GameModes_Server.txt is renamed for the time being until this gets resolved.

Any ideas on how to allow players to join the server AFTER a player has joined?

Sincerely,
Krillin AKA Doc
_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers

Just noticed in the default botprofile.db, the bot's name is spelled
"Pheonix" instead of "Phoenix"


http://www.youtube.com/watch?v=CWrMGXwhFLk&feature=player_detailpage#t=165s

Thou shalt spell the word "Pheonix" P-H-E-O-N-I-X not P-H-O-E-N-I-X, regardless of what the Oxford English Dictionary tells you. 

On Mon, Aug 20, 2012 at 4:52 PM, Absurd Minds <[hidden email]> wrote:
Just noticed in the default botprofile.db, the bot's name is spelled
"Pheonix" instead of "Phoenix"

_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers

Hi all,
 
An update for steamcmd has just been released that will allow you to run multiple instances of it on one machine simultaneously. It will also run on Windows even if the Steam UI is running already.
 
Some notes:
 
·         logging in will still “take” that user session, so it will logout the main client if you use the same account, and running several copies w/ the same account simultaneously is not likely to work well
·         I believe you should be able to run all copies of steamcmd from the same install folder, but I’m not 100% sure (I’ve tested it but not every possible scenario). So be on the lookout for new weirdness.
·         Otherwise, simultaneous instances that are using different accounts should not affect one another at all.
 
regards,
Taylor Sherman
Valve
 

_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers


_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers