Quantcast

Cannot join lobby, response 2!

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Cannot join lobby, response 2!

joshtrav
Some quick background:
Players can join my servers just fine.  There are no issues with the game mode files.  I get 30 players in there without a problem, then all of the sudden, a few will leave, and it will randomly start giving all those connecting these errors:

Unknown command "joingame"
GameTypes: could not find matching game type "".
CSysSessionClient: Cannot join lobby, response 2!

Now the really interesting part is that there are 2 ways to get around this so far.  Reboot the entire server, which sucks, or wait for every player currently playing to leave, also sucks.

Once the last player disconnects from the server, and its 0/30, anyone can join again.  It is truly a mystery as to why, how it occurs, or for the life of me how to stop it.  Does anyone have any sort of info on how to solve it or who can at least comment on other similar issues so we may be able to get it addressed.

-Josh

_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot join lobby, response 2!

Eric Winkelmann
I get this issue as well. It is very, very frustrating. I've had to send out a sm_say quite a few times saying 'Need to reboot server, please rejoin in ~60 seconds.' Someone on my friends list usually lets me know if the issue fairly quickly, but I don't like having to tell everyone to leave and hope they come back...makes my server look...crappy?

On Thu, Oct 18, 2012 at 1:36 AM, Joshua Travis <[hidden email]> wrote:
Some quick background:
Players can join my servers just fine.  There are no issues with the game mode files.  I get 30 players in there without a problem, then all of the sudden, a few will leave, and it will randomly start giving all those connecting these errors:

Unknown command "joingame"
GameTypes: could not find matching game type "".
CSysSessionClient: Cannot join lobby, response 2!

Now the really interesting part is that there are 2 ways to get around this so far.  Reboot the entire server, which sucks, or wait for every player currently playing to leave, also sucks.

Once the last player disconnects from the server, and its 0/30, anyone can join again.  It is truly a mystery as to why, how it occurs, or for the life of me how to stop it.  Does anyone have any sort of info on how to solve it or who can at least comment on other similar issues so we may be able to get it addressed.

-Josh

_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers



--
Eric Winkelmann


_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot join lobby, response 2!

Mike Didiano

Are you sure you have all of your maps in the gamemodes.txt or gamemodes_server.txt?  Are you running any custom maps?

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Eric Winkelmann
Sent: Thursday, October 18, 2012 9:11 AM
To: [hidden email]
Subject: Re: [Csgo_servers] Cannot join lobby, response 2!

 

I get this issue as well. It is very, very frustrating. I've had to send out a sm_say quite a few times saying 'Need to reboot server, please rejoin in ~60 seconds.' Someone on my friends list usually lets me know if the issue fairly quickly, but I don't like having to tell everyone to leave and hope they come back...makes my server look...crappy?

On Thu, Oct 18, 2012 at 1:36 AM, Joshua Travis <[hidden email]> wrote:

Some quick background:

Players can join my servers just fine.  There are no issues with the game mode files.  I get 30 players in there without a problem, then all of the sudden, a few will leave, and it will randomly start giving all those connecting these errors:

 

Unknown command "joingame"

GameTypes: could not find matching game type "".
CSysSessionClient: Cannot join lobby, response 2!

 

Now the really interesting part is that there are 2 ways to get around this so far.  Reboot the entire server, which sucks, or wait for every player currently playing to leave, also sucks.

 

Once the last player disconnects from the server, and its 0/30, anyone can join again.  It is truly a mystery as to why, how it occurs, or for the life of me how to stop it.  Does anyone have any sort of info on how to solve it or who can at least comment on other similar issues so we may be able to get it addressed.

 

-Josh


_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers




--
Eric Winkelmann


_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Cannot join lobby, response 2!

Eric Winkelmann
Yes, I have some custom maps in the gamemodes_server.txt and mapcycle.txt. I use SourceMod's nextmap and rtv plugin's to switch around maps. The server hang ups and 'failed to join session' can occur on all maps - even official ones.

On Sat, Oct 20, 2012 at 8:59 AM, Mike Didiano <[hidden email]> wrote:

Are you sure you have all of your maps in the gamemodes.txt or gamemodes_server.txt?  Are you running any custom maps?

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Eric Winkelmann
Sent: Thursday, October 18, 2012 9:11 AM
To: [hidden email]
Subject: Re: [Csgo_servers] Cannot join lobby, response 2!

 

I get this issue as well. It is very, very frustrating. I've had to send out a sm_say quite a few times saying 'Need to reboot server, please rejoin in ~60 seconds.' Someone on my friends list usually lets me know if the issue fairly quickly, but I don't like having to tell everyone to leave and hope they come back...makes my server look...crappy?

On Thu, Oct 18, 2012 at 1:36 AM, Joshua Travis <[hidden email]> wrote:

Some quick background:

Players can join my servers just fine.  There are no issues with the game mode files.  I get 30 players in there without a problem, then all of the sudden, a few will leave, and it will randomly start giving all those connecting these errors:

 

Unknown command "joingame"

GameTypes: could not find matching game type "".
CSysSessionClient: Cannot join lobby, response 2!

 

Now the really interesting part is that there are 2 ways to get around this so far.  Reboot the entire server, which sucks, or wait for every player currently playing to leave, also sucks.

 

Once the last player disconnects from the server, and its 0/30, anyone can join again.  It is truly a mystery as to why, how it occurs, or for the life of me how to stop it.  Does anyone have any sort of info on how to solve it or who can at least comment on other similar issues so we may be able to get it addressed.

 

-Josh


_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers




--
Eric Winkelmann


_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers



--
Eric Winkelmann


_______________________________________________
Csgo_servers mailing list
[hidden email]
https://list.valvesoftware.com/cgi-bin/mailman/listinfo/csgo_servers
Loading...